Apple Pay is temporarily unavailable for users in UK, Canada, Japan, Hong Kong, and US.

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Oct 19, 2022 - 12:29 AEDT

Identified

We are currently working on a fix.
Posted Oct 19, 2022 - 09:34 AEDT