Unable to access Canva.com in the Philippines

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Aug 18, 2025 - 09:58 AEST

Investigating

We are aware that some users in the Philippines are currently experiencing difficulty accessing Canva. Our team is actively investigating this issue and working to restore normal service. We will provide updates as more information becomes available.
Posted Aug 18, 2025 - 00:30 AEST