Locked Editor / Can’t save design changes
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Mar 18, 2021 - 03:04 AEDT
Identified
We have identified and are fixing a major outage for some customers impacting user's ability to save recent changes in their design.

We continue to work on resolving this for the affected products. We have identified the root cause and are working on ways to expedite the fix.
Posted Mar 18, 2021 - 02:18 AEDT
This incident affected: Mobile Applications (iPad app, iOS app, Android app) and Web Application (Edit Designs).