Some users may have issues accessing Canva

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Apr 29, 2026 - 10:35 AEST

Investigating

Some users may have issues accessing Canva. Our teams are urgently looking into this and we will provide an update soon.
Posted Apr 29, 2026 - 09:24 AEST