Issues uploading videos

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Apr 15, 2022 - 04:14 AEST

Investigating

We received reports about issues with uploading MP4 files.

Our engineers are already investigating the cause of the issue and we will keep you posted through this page.
Posted Apr 15, 2022 - 02:09 AEST