Downloading issue
Incident Report for Canva
Resolved
Thank you for your patience. The downloading issue has been fixed.
Posted 7 months ago. Mar 14, 2019 - 00:37 AEDT
Investigating
We're currently experiencing issues with Downloading. Our engineers are working on fixing this in the soonest possible time.
Posted 7 months ago. Mar 13, 2019 - 23:59 AEDT
This incident affected: Mobile Applications (iPad app, iOS app, Android app) and Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).