Users in Southeast Asia might experience issues viewing image thumbnails on the editor, downloading designs and accessing the Help Center Page.
Incident Report for Canva
Resolved
This incident has been resolved. Thank you for your patience.
Posted Oct 29, 2021 - 00:09 AEDT
Identified
Some users in Southeast Asia might encounter issues with image thumbnails on the editor, downloading designs, and accessing the help page.

We are actively investigating the issue and we'll update this page for any improvements. Thank you for your patience.
Posted Oct 28, 2021 - 22:41 AEDT