Users may experience issues with Canva Al features

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Nov 27, 2025 - 13:04 AEDT

Monitoring

The fix has been put in place and we are monitoring the issue.
Posted Nov 27, 2025 - 12:37 AEDT

Investigating

Users may experience issues with Canva Al features. We are currently investigating the issue and will keep you updated.
Posted Nov 27, 2025 - 12:12 AEDT