Users are experiencing issues using Canva Apps.

Incident Report for Canva

Resolved

We have rolled back a change that was causing issues when users tried to use apps and are currently monitoring the recovery.
Posted Jun 23, 2025 - 12:05 AEST

Update

We have rolled back a change that was causing issues when users tried to use apps and are currently monitoring the recovery.
Posted Jun 23, 2025 - 11:59 AEST

Monitoring

We have rolled back a change that was causing issues when users tried to use apps and are currently monitoring the recovery.
Posted Jun 23, 2025 - 11:53 AEST