Unable to access canva.com
Incident Report for Canva
Resolved
We're glad to let you know that this incident has been resolved. We hope everything is back to normal for you.
Posted Nov 26, 2020 - 04:36 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 26, 2020 - 01:00 AEDT
Investigating
We are aware of reports that some users are encountering errors accessing Canva. We are currently working to resolve the issue.
Posted Nov 26, 2020 - 00:57 AEDT
This incident affected: Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).