Unable to Upload Videos; Stuck In Processing
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 09:39 AEDT
Investigating
We have identified that some users are experiencing a "Stuck in Processing" in the editor when trying to upload videos.

Our engineers are working to resolve the issue and will keep you updated.
Posted Oct 30, 2019 - 03:45 AEDT
This incident affected: Web Application (Image Uploads).