Users are experiencing slow responses and errors when accessing Canva and their designs
Incident Report for Canva
Resolved
This incident has been Resolved.
Posted Jul 21, 2021 - 13:19 AEST
Identified
Users are currently experiencing slow responses and errors when accessing Canva and their designs. We are aware of the issue and our Engineers are working on getting this fixed ASAP. We'll provide further updates as soon as we get them. We appreciate your patience in this matter.
Posted Jul 21, 2021 - 12:58 AEST
This incident affected: Mobile Applications (iPad app, iOS app, Android app) and Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).