Issue with accessing the site
Incident Report for Canva
Resolved
Hello. We are now back! Sorry for the inconvenience that this has caused you. Please let us know if you still continue to experience the same. Cheers!
Posted 4 months ago. Apr 25, 2019 - 02:11 AEST
Investigating
We're currently experiencing issues with accessing the website. Our engineers are working on fixing this in the soonest possible time.
Posted 4 months ago. Apr 25, 2019 - 00:23 AEST
This incident affected: Mobile Applications (iPad app, iOS app, Android app) and Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).