Unable to download designs for some users
Incident Report for Canva
Resolved
Thank you for your patience. The downloading issue has been fixed.
Posted Jun 01, 2019 - 02:57 AEST
Investigating
We’re currently experiencing issues where some users are getting downloading errors . Our engineers are already looking into this.
Posted Jun 01, 2019 - 02:16 AEST
This incident affected: Web Application (Design Downloads / Sharing).