Issues loading log in and security page
Incident Report for Canva
Resolved
Between 2022-08-12 11:33:35 AEST to 2022-08-12 13:28:39 AEST, we experienced an issue with loading the Login & Security page of the Account Settings. The issue has been resolved and the page can now be accessed.
Posted Aug 12, 2022 - 13:38 AEST
Investigating
We received reports where users are having issues accessing the login and security preferences panel under accounts settings. We are already aware of this and are already investigating the cause of the issue.

We will update this page for any progress or when the fix is rolled out.
Posted Aug 12, 2022 - 12:16 AEST