Users unable to Download designs.
Incident Report for Canva
Resolved
This incident has been resolved. Thank you for your patience and understanding.
Posted 13 days ago. Aug 09, 2019 - 00:59 AEST
Update
We are continuing to investigate this issue.
Posted 13 days ago. Aug 09, 2019 - 00:36 AEST
Investigating
We are already aware of the issue and we're currently working on a fix. Thank you for understanding.
Posted 13 days ago. Aug 09, 2019 - 00:33 AEST
This incident affected: Web Application (Design Downloads / Sharing).