Users might experience latency on Canva. Some features might also show an error.

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 15:31 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2025 - 11:53 AEST

Investigating

We are currently investigating the issue
Posted Jul 03, 2025 - 11:35 AEST
This incident affected: Editing designs, Viewing designs, Saving designs, Downloading designs, Sharing designs, Media uploads, Home page, Projects page, Templates page, Apps, and Scheduling posts.