Saving not working
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 01:24 AEST
Investigating
Users are unable to save their designs.
Posted Jul 14, 2020 - 01:09 AEST