Some users may have issues downloading video designs

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Jul 13, 2026 - 03:29 AEST

Identified

Some users may experience issues downloading video designs. Our teams are currently working to resolve the issue.
Posted Jul 12, 2026 - 18:38 AEST
This incident affected: Designs (Downloading designs).