Some users may encounter issues accessing Canva.com

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Jun 21, 2022 - 17:43 AEST

Update

We're in contact with our cloud provider to resolve the issue as soon as possible. Thank you for your patience and understanding.
Posted Jun 21, 2022 - 17:05 AEST

Investigating

Our team is currently investigating the issue. We apologize for the inconvenience.
Posted Jun 21, 2022 - 16:51 AEST