Users unable to access Canva.com, getting "504 Gateway Time-out" error.
Incident Report for Canva
Resolved
This issue should now be resolved. Please refresh your browser and try again.
Posted Sep 23, 2020 - 03:59 AEST
Investigating
We're receiving reports from users that they are unable to access Canva.com with a 504 Gateway Time-out error. Others can log in to Canva but designs could not be loaded.

We're currently investigating the issue and working hard to resolve it as soon as possible.
Posted Sep 23, 2020 - 03:40 AEST