Users may experience out of date thumbnails.

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Dec 01, 2022 - 13:36 AEDT

Identified

The issue has been identified and a fix is being implemented. Thank you for your patience and understanding.
Posted Dec 01, 2022 - 08:13 AEDT

Update

This issue is now affecting print previews.
Posted Dec 01, 2022 - 02:02 AEDT

Investigating

We are aware of this issue and currently investigating. Thank you for your patience.
Posted Dec 01, 2022 - 01:33 AEDT