Unable to access Canva. Users are getting an "error 500"
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Aug 12, 2021 - 14:24 AEST
Investigating
We are currently investigating this issue.
Posted Aug 12, 2021 - 14:09 AEST
This incident affected: Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).