Some users may have issues with payments in Canva

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Aug 01, 2026 - 05:58 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 01, 2026 - 05:24 AEST

Identified

We've identified an issue affecting subscriptions, billing and payments in Canva. Our teams are working to fix the problem.
Posted Aug 01, 2026 - 05:02 AEST

Investigating

Some users may have issues using Canva. Our teams are urgently looking into this and we will provide an update soon.
Posted Aug 01, 2026 - 04:55 AEST
This incident affected: Billing and subscriptions.