Error 500 accessing Canva
Incident Report for
Canva
Resolved
This incident has been resolved.
Posted
Nov
03
,
2018
-
04:40
AEDT
Investigating
We’re currently aware of an issue upon accessing Canva. We’re doing our best to resolve this ASAP and will provide updates.
Posted
Nov
03
,
2018
-
04:12
AEDT
×
Subscribe to Incident
Subscribe to updates for
Error 500 accessing Canva
via .