Some users in Brazil may experience failure accessing Canva due to network issues.
Incident Report for Canva
Resolved
The issue has now been resolved. Thank you for your patience and understanding.
Posted Mar 04, 2022 - 15:59 AEDT
Investigating
We are currently investigating an issue with network performance in São Paulo Brazil. We appreciate your patience and understanding.
Posted Mar 04, 2022 - 11:36 AEDT