Some users may get an error when accessing design
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 15:55 AEST
Investigating
We are currently investigating the issue. We apologize for the inconvenience.
Posted Sep 21, 2022 - 15:42 AEST