This incident is now resolved. Thank you for your patience and understanding.
Posted Jun 12, 2026 - 16:25 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2026 - 15:16 AEST
Identified
Users may experience intermittent issues when using Canva.
Our engineers have identified the issue and are working on a fix.
Posted Jun 12, 2026 - 14:45 AEST
This incident affected: Login and signup, Editing designs, Viewing designs, Downloading designs, Sharing designs, Media uploads, Home page, Projects page, and Templates page.