Some users from Turkey might experience downloading and saving difficulties
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Dec 27, 2022 - 14:08 AEDT
Investigating
We are currently investigating this issue.
Posted Dec 27, 2022 - 11:11 AEDT
This incident affected: Web Application (Design Downloads / Sharing, Edit Designs).