This incident is now resolved. Thank you for your patience and understanding.
Posted Mar 23, 2026 - 10:09 AEDT
Monitoring
We’ve applied a fix for this issue and are currently monitoring to make sure everything is working as expected. We’ll continue to keep a close eye on things and share any updates if needed.
Posted Mar 23, 2026 - 09:44 AEDT
Investigating
Users may have issues loading Canva. Opening designs may yield a 503 error. We are currently investigating the issue and will keep you updated.