Some users may encounter error in accessing Canva
Incident Report for Canva
Resolved
This incident is now resolved.
Posted Aug 02, 2022 - 12:11 AEST
Monitoring
We are aware that some of our users will have an issue accessing Canva. Our team is now working on a fix.
Thank you for your patience and understanding.
Posted Aug 02, 2022 - 11:46 AEST