Downloading issues
Incident Report for Canva
Resolved
We're glad to let you know that this incident has been resolved. We hope everything is back to normal for you.
Posted Nov 09, 2020 - 02:47 AEDT
Monitoring
We are currently investigating the issue to make sure that this is resolved the soonest possible time.
Posted Nov 09, 2020 - 02:03 AEDT
This incident affected: Web Application (Design Downloads / Sharing).