Unable to download designs
Incident Report for Canva
Resolved
Hello! Thank you for your patience and understanding. Canva is now up and running again. Please refresh your browsers and try downloading your designs again. Let us know if you need anything else.
Posted 5 months ago. May 26, 2019 - 10:13 AEST
Investigating
We are now aware of an issue wherein users are unable to download their designs. Our team is now looking into it and working on a fix the soonest possible time. Please stay tuned for more updates.
Posted 5 months ago. May 26, 2019 - 08:58 AEST
This incident affected: Web Application (Design Downloads / Sharing).