Unable to access Canva
Incident Report for
Canva
Resolved
This incident has been resolved.
Posted
Dec
10
,
2020
-
23:28
AEDT
Update
We are continuing to investigate this issue.
Posted
Dec
10
,
2020
-
23:24
AEDT
Investigating
We're getting reports that users who are on Sky Internet service provider are experiencing issues accessing Canva.
Posted
Dec
10
,
2020
-
20:12
AEDT
This incident affected: Mobile Applications (iPad app, iOS app, Android app) and Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).
×
Subscribe to Incident
Subscribe to updates for
Unable to access Canva
via . You'll receive .