Downloading design causes "Something went wrong" error
Incident Report for Canva
Resolved
Hi there, sorry for the hiccups. Canva is now back up and running. Please refresh your browsers and try again. Happy designing!
Posted Apr 21, 2020 - 12:07 AEST
Investigating
We are continuing to investigate this issue and ensure to fully resolve it as soon as we can.
Posted Apr 21, 2020 - 11:35 AEST
This incident affected: Web Application (Design Downloads / Sharing).