Unable to create, edit or save designs error 503
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Jun 25, 2021 - 23:53 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2021 - 23:52 AEST
Investigating
We are currently investigating this issue.
Posted Jun 25, 2021 - 23:20 AEST
This incident affected: Web Application (Design Downloads / Sharing, View Designs, Edit Designs).