Users may have issues with subscribing through Apple
Incident Report for
Canva
Resolved
This incident has been resolved.
Posted
Feb
06
,
2023
-
11:15
AEDT
Investigating
We are currently investing issues affecting users from subscribing through Apple
Posted
Feb
06
,
2023
-
11:10
AEDT
×
Subscribe to Incident
Subscribe to updates for
Users may have issues with subscribing through Apple
via . You'll receive .