"This site can't be reached" error
Incident Report for Canva
Resolved
We're glad to let you know that this incident has been resolved. We hope everything is back to normal for you.
Posted Dec 02, 2020 - 17:18 AEDT
Investigating
We're aware that some users are unable to access Canva. Our team is investigating this issue and we'll share updates here.
Posted Dec 02, 2020 - 04:14 AEDT
This incident affected: Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).