Delay in notification for pick-up orders
Incident Report for Canva
Resolved
Between 2022-05-30 00:30 UTC to 2022-05-31 21:50 UTC, we experienced delays in receiving notification for pickup orders in the US region. This issue has now been resolved.
Posted Jun 01, 2022 - 07:58 AEST
Investigating
We are experiencing slight delays in notifications for print orders that are ready for pick-up in US regions. We are working on fixing this asap and we apologize for the inconvenience.

We will let you know as soon as we have an update.
Posted May 30, 2022 - 12:37 AEST