Users are sometimes unable to place Print orders in non-local currencies
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Mar 02, 2022 - 17:55 AEDT
Identified
Currently, some users are getting errors when placing Print orders which require currency conversion. We are aware of the issue and are working on getting this fixed. We’ll let you know as soon as we get updates. Your patience on this matter is highly appreciated.
Posted Mar 02, 2022 - 13:46 AEDT