Slow video and image export

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Jul 14, 2023 - 13:05 AEST

Update

We have identified that the problem is also impacting the download of PDFs and the publishing of websites. Please be assured that we are actively working on resolving this issue.
Posted Jul 13, 2023 - 21:35 AEST

Update

We are continuing to investigate this issue.
Posted Jul 13, 2023 - 21:16 AEST

Investigating

We have been informed of delays in video and image downloads. Our team is actively investigating this issue.
Posted Jul 13, 2023 - 19:36 AEST
This incident affected: Downloading designs.