Error accessing Canva in Kazakhstan
Incident Report for Canva
Resolved
This issue has been resolved.
Posted Oct 02, 2024 - 11:34 AEST
Monitoring
We are aware of the issue and working on it.
Posted Sep 28, 2024 - 00:51 AEST