Users experiencing increase in timeout errors affecting image generation.

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Sep 05, 2025 - 14:29 AEST

Investigating

Users experiencing increase in timeout errors affecting image generation in our Dream Lab, Canva AI, and Magic Media products. We’ve identified the root cause and are actively working on a fix.
Posted Sep 05, 2025 - 10:50 AEST