Error 500 when accessing Canva Homepage and Log in page
Incident Report for Canva
Resolved
This incident has been resolved. Thank you so much for your understanding.
Posted Mar 09, 2022 - 01:45 AEDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 09, 2022 - 01:09 AEDT
Identified
We received reports about errors when accessing Canva. We are aware of the issue and are already working on have this issue fixed.
Thank you so much for your understanding and we will update this page for any progress.
Posted Mar 09, 2022 - 01:08 AEDT