Some users might not be able to access Canva
Incident Report for
Canva
Resolved
This incident has now been resolved.
Posted
May
25
,
2022
-
12:44
AEST
Investigating
We're experiencing an elevated level of errors and we are currently looking into Canva being down to a large number of users.
Posted
May
25
,
2022
-
12:21
AEST
×
Subscribe to Incident
Subscribe to updates for
Some users might not be able to access Canva
via . You'll receive .