Users may be experiencing issues downloading designs
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 11:28 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 13, 2022 - 10:45 AEDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 13, 2022 - 10:41 AEDT
Investigating
We are currently investigating an issue with downloading designs.
Posted Oct 13, 2022 - 10:38 AEDT
This incident affected: Web Application (Design Downloads / Sharing).