Users are experiencing issues loading Canva

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Nov 19, 2025 - 01:56 AEDT

Update

We've implemented a fix and monitoring results.
Posted Nov 19, 2025 - 01:48 AEDT

Monitoring

We've implemented a fix and monitoring results.
Posted Nov 19, 2025 - 01:06 AEDT

Update

We are working with Cloudflare to fix the issue.
Posted Nov 19, 2025 - 00:39 AEDT

Update

Our CDN provider Cloudflare is having issues resulting in Canva being unable to load for some users. Please refer to https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 23:30 AEDT

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 23:22 AEDT

Identified

Users may be unable to load Canva.
Posted Nov 18, 2025 - 23:04 AEDT
This incident affected: Mobile Applications (iPad app, iOS app, Android app), Login and signup, Editing designs, Viewing designs, Saving designs, Downloading designs, Sharing designs, Media uploads, Home page, Projects page, Templates page, Apps, Administration and settings, Billing and subscriptions, Print and delivery, Scheduling posts, Publishing websites, Help/support, Apps SDK, Connect API, Canva AI Connector, Document import, Desktop Applications (macOS app, Windows app), and LMS Integrations (Blackboard, Canvas, D2L, Google Classroom, Moodle, MS Teams, Remind, Schoology).