Scheduled Maintenance
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Aug 23, 2021 - 13:46 AEST
Monitoring
We will be performing a scheduled maintenance this Monday, August 23, 2021, starting at exactly 9:00 am AEST up until 1:00 pm AEST.

Canva will still be operational during this time, however, some users might experience degraded performance resulting in errors while accessing the platform.

Our team will be closely monitoring and we'll update this page once everything has been completed.

Thanks,
Canva Team
Posted Aug 23, 2021 - 08:29 AEST