Users located in South Korea may experience difficulties opening the Canva mobile application
Incident Report for Canva
Resolved
This incident is now resolved. Thank you for your patience and understanding.
Posted Apr 04, 2024 - 18:01 AEDT
Identified
Users in South Korea may experience difficulties signing in and accessing their accounts using the Canva mobile application. The application freezes on the Canva logo screen.

Our engineers are working to resolve the issue. We will keep you updated.
Posted Apr 04, 2024 - 13:33 AEDT