Users on BT Internet service provider experience issues when accessing Canva
Incident Report for Canva
Resolved
We're glad to let you know that the issue when accessing Canva for users with BT internet service provider has been resolved. Thank you for your patience!
Posted May 16, 2020 - 11:58 AEST
Update
If your internet provider is British Telecom (BT) and you get an ERR_CONNECTION_TIMED_OUT error when trying to access Canva, we suggest changing your device DNS settings to either Google DNS (8.8.8.8) or Cloudflare DNS (1.1.1.1). To do this, follow the steps specific to your device from this page: https://www.howtogeek.com/167533/the-ultimate-guide-to-changing-your-dns-server/.

We’ve identified that BT’s configuration of the DNS servers is causing the error. We have been trying to reach out to them to assist with resolving the issue. We highly encourage reaching out to your BT provider if you’re experiencing this, and ask them to restore the reachability of www.canva.com.


Why is this happening?

To open www.canva.com, your device needs to resolve the address using the configured DNS server. There is a set of global DNS servers like Google DNS (8.8.8.8) or Cloudflare DNS (1.1.1.1). Canva uses Cloudflare as our DNS provider. However, many Internet providers maintain their own DNS servers. In this case, the DNS server of BT appears to be misconfigured. Instead of resolving to Canva’s IP addresses, it resolves to the IP addresses of BT.

Here's an example:

C:\Users\name> nslookup www.canva.com
...
Non-Authoritive answer:
Name: www.canva.com
Address: 81.130.111.239

C:\Users\name> nslookup www.canva.com 1.1.1.1
...
Non-Authoritive answer:
Name: www.canva.com
Address: 2606:4700::6812:d843
104.18.215.67
104.18.216.67

C:\Users\name> nslookup www.canva.com 8.8.8.8
...
Non-Authoritive answer:
Name: www.canva.com

Address: 2606:4700::6812:d843
104.18.215.67
104.18.216.67

From the data above, we can see that the default DNS server on BT’s network resolves www.canva.com to an IP address that belongs to BT, whereas the global DNS servers resolve www.canva.com to the Canva IP addresses.
Posted May 14, 2020 - 14:19 AEST
Update
We have identified this as an issue with BT DNS servers. As a workaround, you can change your DNS settings on your computer to either Google DNS (8.8.8.8) or Cloudflare DNS (1.1.1.1). You can follow the steps here:

https://www.howtogeek.com/167533/the-ultimate-guide-to-changing-your-dns-server/
Posted May 13, 2020 - 20:37 AEST
Identified
We’re getting reports that users who are on BT Internet service provider are experiencing issues accessing Canva.
Posted May 13, 2020 - 02:32 AEST
This incident affected: Mobile Applications (iPad app, iOS app, Android app) and Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).